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Introduction to Quantum GIS 
This exercise is designed to familiarize you with some basic concepts and capabilities of QGIS. 

You will explore the abilities of Quantum GIS to visualize, navigate, manipulate, and analyze 

geographic datasets.  

 

Specifically, you will learn how to: 

 Create a map project 

 Add layers to your project 

 Display data to your specifications (e.g. colors, symbols, line weights) 

 Navigate the data using the zoom, pan, and full extent tools 

 Identify features and their attribute data 

 Query the map based on your criteria 

 Create Buffers around points 

 Create a map layout 

 

In order to explore these concepts, we will use the datasets listed below to select the best 

locations for community sponsored produce stands. In our imagined scenario, the City of 

Berkeley has assigned you with the task of identifying lower income communities with limited 

access to fresh fruits and vegetables. The City would like to identify five civic buildings that are 

in close proximity to these neighborhoods and place weekly produce stands on their property. 

Therefore, you‟re final product will be a map depicting the location of these potential sites and 

their service areas. 

 

Dataset 
You will be working with several data layers from different sources. Note that a layer is 

comprised of several different files with the same name and different extensions. All these files 

of the same name must be in a folder together for the software to read them.  

 

Berkeley_dem.tif – a raster “digital elevation model” displaying elevation for the City of 

Berkeley and surrounding areas. 

Berkeley_shd.tif – a raster grid file displaying shaded relief based on elevation. 

BerkeleyBlockGroups.shp – polygons containing demographic information for census block 

groups 

Fruit_Vegetable_and_FarmersMarkets.shp – shows point locations for fruit and vegetable 

markets, as well as Farmers Markets 

BerkeleyLimits.shp – polygon of city boundary 

County.shp – polygon of Alameda and Contra Costa Boundaries. 

PublicSites.shp – point locations of public buildings, institutions, and churches. This layer was 

created by combining three shapefiles and removing buildings on the Cal campus. 

 

* Note that all data layers are in the following projection: 

Projection: Universal Transverse Mercator (UTM) 

Datum: North American Datum 1983 (NAD83) 

Zone: 10 North 
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Display Data 
In this section you will add layers to your map project and change their display properties. 

 

Add Data 
1. Open QGIS by going to Start > All Programs > Quantum GIS > Quantum GIS.  

 

2. In QGIS, go to Layer > Add Vector Layer or Click on the Add Data button:  

 

3. Click the Browse button, then navigate to the folder with your data in it, and click „OK‟. 

The folder‟s contents should appear in the window. 

 

4. Add all of the shapefiles to QGIS. You can select multiple files at once by holding the 

Ctrl or Shift keys. 

5. Next, go to Layer > Add Raster Layer or Click on the Add Data button:  

 

6. Set the “Files of Type” to GeoTIFF and add Berkeley_dem.tif and Berkeley_shd.tif to 

the map. 

 

7. Check the boxes to the left of the layer name off and on. As you can see, this makes the 

layer visible or not visible in the data frame. 

 

8. Click and drag the layers in the table of contents to rearrange their order. Arrange the 

layers in this order, from top to bottom:  

 

a. PublicSites 

b. Fruit_Vegetable_and_FarmersMarkets 

c. BerkeleyLimits 

d. BerkeleyBlockGroups 

e. County 

f. Berkeley_shd 

g. Berkeley_dem 

 

 

9. Click the Save Button, navigate to your working directory (the same directory that your 

data is in), and name the file as ‘LASTNAME_GIS_workshop.qgs’. Save your work 

repeatedly throughout this project.  A project file (.qgs) will save your display and layers, 

however it only points to the selected data files.  Data files are maintained separately 

from the project file. 
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Layer properties 
1. Change the BerkeleyLimits polygon to an outline by double clicking its name in the 

table of contents. Go to the “Style” tab, and  

 

2. Increase the width in “Outline options” to 2.0, and Set the “Fill options” to None. 

 

  
 

3. Right-click BerkeleyLimits and select Zoom to Layer Extent. 

 

4. Right-click on the layer: BerkeleyBlockGroups. A context menu appears – Stop for a 

minute and look at the options in this context menu. This menu contains several 

important options. 

 

5. Choose Properties to open the Layer Properties (same as double-clicking). The Layer 

Properties dialog appears. You can access the properties for the other layers in the same 

manner. 
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6. Click on the General tab. You can change the “Display Name” of layer here. This only 

changes how the name is displayed, it does not change the name of the actual file. Type 

Berkeley Census. 

 

7. Click on the Style tab and change the “Legend Type” to Graduated Symbol. In the drop-

down menu for “Classification Field” and Select PERCAPITAI (Per Capita Income). 

These settings will assign color to each polygon based on their per capita income.  Set the 

number of classes to “6”, and click the Classify button. 

 

  
 

8. Redefine the bins for each class by double clicking the number range for each bin and 

manually entering the lower and upper values as seen below:  

 

0-14000 

14000-20000 

20000-25000 

25000-35000 

35000-50000 

50000-85000 

 

Click OK, and you will see the census blocks vary in color according to Per Capita Income. 

 



Introduction to QGIS       Geospatial Innovation Facility 

9. Using the same steps as in items 1 and 2 above, set the County layer‟s Fill options to 

None so that you can see the topography beneath. 

 

 

 
 

10. Change the symbols for the other vector layers so that they are easily distinguishable 

from the Berkley Census. You can change the symbols for layers by clicking on their 

symbol (colored rectangle under the layer name) as described in step 1 of this section.  Be 

sure to make your symbols colors that will stand out and are large enough to see.  

 

 

11. To adjust the Style for the 

raster layers, access the 

layer properties menu for 

berkeley_dem and go to the 

Symbology tab.  Set the 

color map to Pseudocolor, 

and set the option for “Use 

Standard Deviation” to 1.00. 

 

12. Lastly, open the Layer 

Properties for 

Berkeley_shd and go to the 

Transparency tab.  Set the 

Global Transparency to 

60%, which will create a 

3D effect with the DEM.  

You can adjust transparency 
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on any layer to maximize viewing.  Also try moving the semi-transparent Berkeley_shd 

layer above the polygon layers. 

 

 
 

Navigation  
1. Explore the data using some of the navigation tools in the Toolbar: 

 

                       
 

2. Use the magnifying glass tools to draw a rectangle around an area to zoom in or to zoom 

out.  

 

3. Click on the full extent button  to see your entire dataset. 

 

4. Experiment with the other navigation tools to see what they do. 

 

Working with Attribute Data 
Every spatial unit, such as a polygon, point, or pixel may be assigned several values that are 

associated with relevant attributes. These values are stored in the database file (.dbf) and may be 

viewed in an attribute table or using the identify tool. This section explores attribute tables and 

some tools to query them.  
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Attribute Tables 
1. Right-click on Berkeley Census and select “Open Attribute Table.” 

 

2. Explore the table. Each row corresponds to a spatial feature and each column represents 

an attribute.  

 

 

3. Click on the grey box at the beginning of a row, and the corresponding feature is 

highlighted in yellow on the map. Click the  button, and the map zooms in to the 

selected feature. 

 

 
 

4. Click the Unselect all button  at the bottom of the attribute table‟s window to clear 

selection. 

 

Select Features 
1. In the previous section, we selected features from the attributes table.  You can also select 

them directly on the map. Re-adjust your zoom level then choose the Select Features 

button from the Tools toolbar. 

 

2. Click inside of a polygon. Hold the Ctrl key to make multiple selections, 

or drag over a large area while holding the shift key.  You will notice that 

features are highlighted both on the map and in the attribute table. There 

are several different tools for selection that you can try. 
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3. Alternatively, you can also select features based on their attribute values. Clear the 

selected values in the attribute table, and Click on the “Advanced Search” button in the 

bottom right hand corner.  

 

4. The query bulder function is similar to a calculator. We want QGIS to select features 

from Berkeley Census where Per Capita Income (PERCAPITAI) is less than 20,000 

dollars. Double-click on listed terms to insert them into a formula and click on the 

mathematical buttons to insert these. Write the statement as seen below: 

 

 PERCAPITAI < 20000 

 

 
 

5. Click OK.  
6. To export the selected areas, and create a new shapefile with only these areas, Right-click 

Berkeley Census in the table of contents, and click Save Selection as.  Set the Format to 

ESRI Shapefile and browse to C:\WorkSpace\Intro_QGIS\outputs and name the new 

shapefile low_income_areas.shp, and accept the default projection.  You can add this 

new file to your map. 
 

 

Basic Spatial Analyses 
Much of the power of GIS lies in its ability to analyze spatial data. This section introduces 

simple spatial analysis tools. 

 
1. Open the Plugin Manager by selecting Plugins > 

Manage Plugins. Here you will find many 

additional tools that extend the capabilities of 

QGIS.  Check fTools at the bottom of the list, this 

plugin contains a series of valuable analysis tools 

that will show up as a drop down menu called 

“Vector.”  Take a look to see what is available. 
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2. Choose Vector  > Geoprocessing Tools > Buffer(s). 

 

3. As seen in the figure below, use the drop-down list to select 

Fruit_Vegetable_and_FarmersMarkets as the input vector layer. Set a buffer distance 

of 1000 (units are in meters), and click browse to select a folder and name to save the 

new buffer polygon shapefile.  Name the new file MarketsBuffer.shp and click OK. 

 

 
 

4. Click “Yes” to add the new file to your map, and close the buffer dialog box. 
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Difference 
1. Choose Vector > Geoprocessing Tools > Difference. 

 

2. Using this tool, we will identify the low income areas that are greater than 1km from a 

fruit and vegetable or farmers market. Set low_income_areas as the Input vector area, 

and MarketsBuffer and the Difference Layer. 

 

3. Save the new feature as underserved.shp.  

 

4. Click OK. 

 

5. Turn off the Buffer layer. Your new layer should show only low income areas that are 

greater than 1km from markets. 

 

6. Clear your selected features by clicking on View  > deselect features from all layers in the 

drop down menu at the top of the window. 

 

Expert Opinion 
Since the city is asking you to choose these sites, we can‟t let the GIS do all of the work. Select 

five sites from the candidates based on their service areas and your knowledge of the area. 

Which sites will best serve the community? 

 

1. Choose the Selection tool . 

 

2. Make sure that PublicSites and UnderservedAreas are both visible on your map. 

 

3. Use the Select feature tool and highlight five Public Sites that could represent good sites 

for community produce stands, based on their proximity to underserved areas. Hold the 

Ctrl key to select multiple features.  
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4. Right click PublicSites.shp in the table of contents and Save selection as to create a new 

output of your five selected points.  Name the file ProposedSites.shp.  

 

5. Hide the other public sites, and create 1km buffer around ProposedSites using the steps 

described in the previous buffer section.  

  

Exporting Data 
Most people do not have access to GIS, so we must consider how we will share our data with the 

rest of the world. This section will teach you how to export your data to other formats while 

emphasizing quality map design. 

 

Print Layouts 
1. Adjust your layers symbology to create a compelling map layout in your viewer before 

entering the QGIS print composer. 

 

2. Enter the Print Composer by selecting File > Print Composer in the drop-down menus.  

 

3. In the new window that opens, click the Add Map tool , and drag a box over the 

blank workspace. 

 

 
 

4. Add a scale bar to the map using the add new scalebar tool  and clicking on the 

map.  You can adjust the style and numbering under the Item tab while the scale bar is 

highlighted. 
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5. Change the “Map units per bar units” to 1000 to convert meters to kilometers, and add km 

to the “unit label.” 

 

6. Add a legend to the map by selecting the add legend tool   and click to place on the 

layout.  Use the options under the Item tab to adjust the legend to your liking.  You can 

move items up and down and edit their names here.   

 

7. Add a title to the map using the add new label tool  .  You can adjust the text under 

the item tab, and size and position by dragging the blue squares on the map. 

 

8. Spend some time making adjustments to the map (layer colors and textures) and don‟t be 

afraid to make your map unique.   

 

 
 

Export as digital image 
 

1. Under the General tab, you can adjust the Print Quality of your map.  Choose lower 

resolution (72-100 dpi) for powerpoint, and higher resolution (300-600) for print. 

 

2. Choose the Export as image button to save your map layout.  You can choose from 

several different file types to output. 

 

3. Use the drop down menu to save as type .jpg.  Name the map Berkeley_map.jpg.  Find 

your file in Windows Explorer and open it to view!   


